Website Saving and Loading Issues
Incident Report for Paperless Post
Resolved
Everything is running smoothly, and this incident is resolved. Please reach out to us at help@paperlesspost.com if we can help with any questions.
Posted Jul 31, 2023 - 16:51 EDT
Monitoring
We have rolled out a fix to address the saving and loading issues. We are continuing to monitor the site, and will provide a final update once everything is stable.
Posted Jul 31, 2023 - 12:12 EDT
Investigating
We are currently seeing errors with loading pages and saving Cards and Flyers on our site and are investigating the cause.
Posted Jul 31, 2023 - 11:49 EDT
This incident affected: Website.