We have received confirmation from our third-party partner that the issue is fully resolved.
Posted Apr 23, 2025 - 19:29 EDT
Monitoring
Our third-party email sending partner has implemented a fix to allow delayed emails to be sent. We are seeing on our end that the delayed emails are now successfully going through. We will continue to monitor for stability.
Posted Apr 23, 2025 - 18:17 EDT
Identified
We have identified that our third-party email sending partner is experiencing intermittent delays delivering emails due to a service outage.
Your Card or Flyer sent via email may remain in "Sending..." status during this time. We are monitoring the issue and will ensure your affected messages are sent once our third-party partner is fully back online.
Posted Apr 23, 2025 - 17:35 EDT
This incident affected: Email Sending, iOS App, and Android App.