Add Recipients/Guests and Tracking Page Issue
Incident Report for Paperless Post
Resolved
Thank you for your patience. We have fully resolved this issue with the Add Guests/Recipients pages and Tracking pages at this time. Everything should now be loading as expected. Let us know if we can help with anything else: https://www.paperlesspost.com/contact
Posted Jul 19, 2021 - 13:33 EDT
Identified
We are currently experiencing an unexpected issue with the Add Guests/Recipients pages and Tracking pages for our online cards. We have identified the cause and will provide an update once a solution has been implemented. Thank you for your patience.
Posted Jul 19, 2021 - 13:09 EDT
This incident affected: Website and Email Sending.