Support ticketing system down
Incident Report for Paperless Post
Resolved
Our support ticketing system is back up and you can contact us via the Contact Us form, as well as access our Help Center. We apologize for the inconvenience.
Posted Apr 22, 2016 - 14:50 EDT
Identified
Our support ticketing system is currently down, so support requests and phone calls are not being routed to the team. We are waiting for a solution from our vendor. Please email help@paperlesspost.com directly, and we will get to your query as soon we can.
Posted Apr 22, 2016 - 14:04 EDT