Website Loading Issues
Incident Report for Paperless Post
Resolved
The site has remained stable and is performing as expected. Please reach out to us at help@paperlesspost.com if we can help with any questions.
Posted Nov 29, 2021 - 15:48 EST
Monitoring
Our website is currently stable -- invitations and the My Events page should now be loading as expected. We will continue to monitor and provide a final update once we can confirm the site is performing as expected.
Posted Nov 29, 2021 - 13:20 EST
Investigating
We are currently experiencing an unexpected site outage and are investigating the cause. Our apologies for the inconvenience -- we will provide updates as they are available.
Posted Nov 29, 2021 - 12:10 EST
This incident affected: Website, Email Sending, and Image Rendering and Loading.