Broken Card Links
Incident Report for Paperless Post
Resolved
This incident has been resolved, and all affected card designs are back online.
Posted Jun 18, 2023 - 12:16 EDT
Identified
We have identified an issue that is causing many of our Card pages to be inaccessible or show as broken links. Our team is currently working on a resolution.
Posted Jun 15, 2023 - 10:23 EDT
This incident affected: Website.