Site Outage

Incident Report for Paperless Post

Resolved

We have fully resolved the site outage, and you are again able to log in and access your Cards and Flyers. Let us know if we can help with anything else!
Posted Jan 09, 2023 - 13:47 EST

Investigating

We are currently experiencing an unexpected site outage and are investigating the cause. Our apologies for the inconvenience.
Posted Jan 09, 2023 - 13:39 EST
This incident affected: Website.