Issue detected preventing successful logins
Incident Report for Paperless Post
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 17, 2016 - 20:46 EDT
Identified
We've identified a problem that is preventing users from logging into their accounts and are working to resolve it now. This does not affect the viewing of events by recipients or users who are already logged into the site.
Posted almost 2 years ago. Sep 17, 2016 - 13:14 EDT