Card Sending Issues
Incident Report for Paperless Post
Resolved
This issue has been resolved and previously dispatched emails are being delivered normally now.
Posted 10 months ago. Oct 17, 2017 - 15:07 EDT
Investigating
We are investigating the cause of an issue with sending cards. Thanks for your patience as we work on this!
Posted 10 months ago. Oct 17, 2017 - 14:00 EDT