Sending issue 5/2
Incident Report for Paperless Post
Resolved
This incident has been resolved.
Posted over 1 year ago. May 02, 2017 - 20:26 EDT
Investigating
We are currently investigating an issue that's affecting email and message sending for some users.
Posted over 1 year ago. May 02, 2017 - 16:09 EDT