Delays in dispatching cards sent on 4/19
Incident Report for Paperless Post
Resolved
This incident has been resolved.
Posted 9 months ago. Apr 21, 2017 - 16:41 EDT
Investigating
We are still investigating residual sending delays from the 4/19 incident. New cards should not be affected by this issue.
Posted 9 months ago. Apr 20, 2017 - 11:28 EDT