Delayed Email Sending
Incident Report for Paperless Post
Resolved
This issue has been resolved - sending times have returned to normal.
Posted over 1 year ago. Apr 19, 2017 - 20:08 EDT
Investigating
We are currently investigating an issue that's affecting email and message sending for some users.
Posted over 1 year ago. Apr 19, 2017 - 13:09 EDT