scheduled maintenance
Incident Report for Paperless Post
Resolved
This incident has been resolved.
Posted about 1 year ago. Apr 30, 2017 - 09:48 EDT
Monitoring
Hello! Paperless Post is down for scheduled maintenance, as we conduct a series of major infrastructure improvements to give our customers a better site experience. We expect to be fully functional by 1pm ET, so we suggest that you come back after that time. We apologize for the inconvenience and interruptions caused by this downtime, and thank you for your patience!
Posted about 1 year ago. Apr 30, 2017 - 05:01 EDT