Site outage 5/31
Incident Report for Paperless Post
Resolved
The issues with cards sending is resolved! If you weren’t able to click “send”, you can try now. Or if your cards are “sending” on your tracking page, refresh to see updated statuses. Please reach out to help@paperlesspost.com if you still need assistance.

Thank you for your ongoing patience during these issues. The provider that housed some of our servers lost power yesterday evening, resulting in an outage on our site and a delay in sending cards that were en route during that period. Our apologies again for the delay!
Posted about 1 year ago. Jun 01, 2018 - 15:18 EDT
Update
We are continuing to investigate issues with cards sent during the outage last night.
Posted about 1 year ago. Jun 01, 2018 - 10:26 EDT
Investigating
We're currently experiencing an outage and are actively looking into the cause of the issue. We are working to get the site back up and and running as soon as possible.
Posted about 1 year ago. May 31, 2018 - 18:10 EDT
This incident affected: Website, Email Sending, Image Rendering and Loading, and Payment Processing.