Bounced Emails
Incident Report for Paperless Post
Resolved
This incident has been resolved.
Posted about 1 year ago. Jan 04, 2017 - 23:48 EST
Identified
The issue has been identified.
Posted about 1 year ago. Jan 03, 2017 - 10:22 EST
Investigating
We are currently investigating an issue causing some emails sent through the site to bounce to valid email addresses. We apologize for the inconvenience this is causing in the meantime.
Posted about 1 year ago. Jan 03, 2017 - 10:22 EST