E-mail Sending Delays
Incident Report for Paperless Post
Resolved
This issue has been resolved.
Posted 4 months ago. Sep 07, 2017 - 10:16 EDT
Monitoring
Email sending times should be back to normal. All emails should have been cleared from our queue and delivered to guest & recipient inboxes by now.
Posted 4 months ago. Sep 06, 2017 - 21:48 EDT
Identified
We are currently experiencing a delay with email sending. Our apologies for any inconvenience in the interim!
Posted 4 months ago. Sep 06, 2017 - 17:20 EDT